Документ «Премия». Ошибка редактирования НДФЛ.

Want create site? Find Free WordPress Themes and plugins.

Описание ситуации:

При редактировании суммы НДФЛ любого сотрудника в документе «Премия», суммы НДФЛ других сотрудников очищаются.

Релизы конфигурации, в которых выявлено данное поведение:

ЗУП, ЗУП Корп. 3.1.2.213 и более ранние.

Краткое описание причины:

При возврате отредактированной таблицы налога в документ, эта таблица загружается, хотя в ней находятся данные только по одному сотруднику

Способ устранения или обхода:

Исправление процедуры «ОбновитьДанныеНДФЛНаСервере» в форме документа премии:

&НаСервере
Процедура ОбновитьДанныеНДФЛНаСервере(АдресВременногоХранилища)

    Параметр = ПолучитьИзВременногоХранилища(АдресВременногоХранилища);

    //[+] pro-zup.info
    Отбор = Новый Структура;
    //В таблицах параметра по одной строке
    Отбор.Вставить("ИдентификаторСтрокиНДФЛ", Параметр.НДФЛ[0].ИдентификаторСтрокиНДФЛ);
    СтрокиСотрудника = Объект.НДФЛ.НайтиСтроки(Отбор);
    Если СтрокиСотрудника.Количество() > 0 Тогда
        ЗаполнитьЗначенияСвойств(Объект.НДФЛ[0], СтрокиСотрудника[0]);
    Иначе
        ЗаполнитьЗначенияСвойств(Объект.НДФЛ.Добавить(), СтрокиСотрудника[0]);
    КонецЕсли;
    //Объект.НДФЛ.Загрузить(Параметр.НДФЛ);
    Отбор.Вставить("ИдентификаторСтрокиНДФЛ", Параметр.ПримененныеВычетыНаДетейИИмущественные[0].ИдентификаторСтрокиНДФЛ);
    СтрокиСотрудника = Объект.ПримененныеВычетыНаДетейИИмущественные.НайтиСтроки(Отбор);
    Если СтрокиСотрудника.Количество() > 0 Тогда
        ЗаполнитьЗначенияСвойств(Объект.ПримененныеВычетыНаДетейИИмущественные[0], СтрокиСотрудника[0]);
    Иначе
        ЗаполнитьЗначенияСвойств(Объект.ПримененныеВычетыНаДетейИИмущественные.Добавить(), СтрокиСотрудника[0]);
    КонецЕсли;
    //Объект.ПримененныеВычетыНаДетейИИмущественные.Загрузить(Параметр.ПримененныеВычетыНаДетейИИмущественные);

    //pro-zup.info
    ИзмененныеДанные.Загрузить(Параметр.ИзмененныеДанные);

    Если ИзмененныеДанные.Количество() = 0 Тогда
        Возврат;
    КонецЕсли;

    Модифицированность = Истина;

    ОписаниеТаблицы = ОписаниеТаблицыНДФЛ();
    РассчитатьВсеНаСервере(ОписаниеТаблицы);

КонецПроцедуры
Did you find apk for android? You can find new Free Android Games and apps.

Добавить комментарий